Webhook insecure requests

ssl

#1

I started to write an integration for Zulip chat. Both my RhodeCode installation and Zulip are placed in virtual hosts on the same machine. Zulip is using a self-signed certificate. When RhodeCode tries to post the webhook data it fails to verify the certificate.

Is there a way to allow “insecure” https connections for my webhook?


#2

Not now unfortunately.

We’ll think about adding an verify https flag into the integrations at one point. In the meantime you can edit your installation to not verify the SSL certificates, just change it here: https://code.rhodecode.com/rhodecode-enterprise-ce/files/f2a4f55df5d1a994bcdc33e557e3ba17af9e1b49/rhodecode/integrations/types/webhook.py#L250

and add

req_session.verify = False

Best,


#3

OK, thank you!

Best,