VCS Server 4.26.0 not serving content - Ubuntu 20.04 LTS


I am new to RhodeCode and have tried to install the CE 4.26.0 on Ubuntu 20.04 LTS. Since this is meant to be a test installation, I used sqlite and both the VCS Server and the Community Server are up and running according to rccontrol.

However, while localhost:10020 gives me the RhodeCode dashboard, a call to localhost:10010 only comes back with {“status”: “404 NOT FOUND”}.

I verified the instance status and also the settings in the .ini files and all seems ok. The processes are up and running and netstat reports the correct IPs and Ports are being listened to.

I am at a loss what to do or check next and any help with this would be greatly appreciated.


Hi Marie,

this is fine, you should only connect to 10020 port where RhodeCode is running, then it communicates to VCSServer on it’s own.

Thanks, this worked! Can you say WHY there is a URL given to the VCS server when doing rccontrol status? Does not seem to make sense if there is nothing being served under that URL?? :innocent:

VCSServer URL is there for scaling and potentially having multiple VCSServer URLs that RhodeCode main web can connect too.