New Server; pytz not given correct timezone value


I’m putting together a work flow to get RhodeCode installed and was praising myself till I came to a new server. The Community instance simply isn’t installing, crying about timezone value being null.

I am struggling with the following traceback:

Traceback (most recent call last):
File “/opt/rhodecode/store/khmw04fzpjqmckrn03ndzkl6zykd5zbi-python2.7-rhodecode-enterprise-ce-4.16.2/bin/.rc-setup-app-wrapped”, line 8, in
from rhodecode.lib.rc_commands.setup_rc import main
File “/opt/rhodecode/store/khmw04fzpjqmckrn03ndzkl6zykd5zbi-python2.7-rhodecode-enterprise-ce-4.16.2/lib/python2.7/site-packages/rhodecode/lib/rc_commands/”, line 26, in
from rhodecode.lib.db_manage import DbManage
File “/opt/rhodecode/store/khmw04fzpjqmckrn03ndzkl6zykd5zbi-python2.7-rhodecode-enterprise-ce-4.16.2/lib/python2.7/site-packages/rhodecode/lib/”, line 44, in
from rhodecode.model.repo import RepoModel
File “/opt/rhodecode/store/khmw04fzpjqmckrn03ndzkl6zykd5zbi-python2.7-rhodecode-enterprise-ce-4.16.2/lib/python2.7/site-packages/rhodecode/model/”, line 36, in
from rhodecode.lib.hooks_base import log_delete_repository
File “/opt/rhodecode/store/khmw04fzpjqmckrn03ndzkl6zykd5zbi-python2.7-rhodecode-enterprise-ce-4.16.2/lib/python2.7/site-packages/rhodecode/lib/”, line 32, in
from rhodecode.lib import helpers as h
File “/opt/rhodecode/store/khmw04fzpjqmckrn03ndzkl6zykd5zbi-python2.7-rhodecode-enterprise-ce-4.16.2/lib/python2.7/site-packages/rhodecode/lib/”, line 664, in
local_timezone = tzlocal.get_localzone()
File “/opt/rhodecode/store/s9hw9g4d4q4rdayn70d3iqkc3b9kqc7d-python2.7-tzlocal-1.5.1/lib/python2.7/site-packages/tzlocal/”, line 131, in get_localzone
_cache_tz = _get_localzone()
File “/opt/rhodecode/store/s9hw9g4d4q4rdayn70d3iqkc3b9kqc7d-python2.7-tzlocal-1.5.1/lib/python2.7/site-packages/tzlocal/”, line 70, in get_localzone
return pytz.timezone(etctz.replace(’ ', '
File “/opt/rhodecode/store/khmw04fzpjqmckrn03ndzkl6zykd5zbi-python2.7-rhodecode-enterprise-ce-4.16.2/lib/python2.7/site-packages/pytz/”, line 174, in timezone
raise UnknownTimeZoneError(zone)
pytz.exceptions.UnknownTimeZoneError: ‘’
Configuration of RhodeCode Community failed.
Failed to create: community-6

I have tried everything I can think of, tried replacing the installed pytz from my RhodeCode installation and so on, just not getting anywhere. VCSServer logs show the instance being configured with en_US.UTF8 etc but to no avail - and it provides same error with or without VCSServer installed. Must of self-destroy’ed 6/7 times now.

If someone could help that would be fantastic.

Well, 16 hours of fixing the software and it was the system tzselect tool that saved the day. Simply run that and append profile updates for timezone support via the system. I simply ran tzselect and made my choice and suddenly, I get no errors.

This might be useful for those who are starting from scratch, with a truly barebone OS.

Kind regards


Thanks for the details of this problem. I think we might add this check into the installer. There are several checks in place that require the minimum to install.

I think adding that check could save someone troubles in the future. !