Mysql: (OperationalError) (1071, 'Specified key was too long; max key length is 1000 bytes')


#1

ON some Mysql setups this problem can happen:

(OperationalError) (1071, ‘Specified key was too long; max key length is 1000 bytes’)

One solution we know it’s working is to add into configuration:

sql-mode="NO_ENGINE_SUBSTITUTION" 
default-storage-engine=InnoDB

Another user pointed our that he had to disable STRICT_TRANS_TABLES and was able to complete the installation.

to check the current operating mode run:

SELECT @@GLOBAL.sql_mode, @@SESSION.sql_mode;