Docker migration issue (SVN): "Could not find the requested file system"


I’m struggling migrating my legacy CE 4.27.1 installation to the new Docker method. I did all following the migration docs, I’m on 4.28.0 on the migrated installation and I have all my SVN repos, commits, files etc. perfectly visible in the Rhodecode GUI.

Unfortunately SVN clients (in this case Tortoise SVN) do not like the migrated installation. I can’t do any action, always receiving the error message in Tortoise “Could not find the requested file system”.

I did all the stuff twice with the same result, and after hours I’m helpless at this point.

Any ideas?


Can you check what is the output of .rcstack stack rhodecode logs -f svn when doing svn operations ?

It should show any potential issues on svn system.

Also please check if svn proxy adjustment Migration to Docker & Rcstack - RhodeCode rcstack 5.13.0 documentation

Was also done.


I found that clicking the button “Generate Apache Config” near the SVN proxy configuration and restarting everything solved this.

However, upgrading from 4.28.0 to 5.0.3 killed everything, containers “rc_cluster_apps-celery-1”, "rc_cluster_apps-celery-beat-1 " and "rc_cluster_apps-rhodecode-1 " are permanately restarting after the upgrade.

I’m using docker in many projects, but this new Rhodecode implentation really drives me crazy. It was that easy before. I’ll create a new discussion fot that issue …

Thanks for confirmation, we’ll add an explicit message about this into the migration docs. The 4.X → 5.X migration is a huge steps, sorry it hasn’t been smooth for you.

We’ll improve the docs today on this.