Cloning problem over SSL

ssl
clone
invalid-clone-url

#22

It seems that the CA certificates are not found. This should be mainly related to the VCSServer. Here are some options to try out in order to verify this assumption:

  • Set an environment variable SSL_CERT_FILE for the VCSServer, pointing to ~/.rccontrol-profile/etc/ca-bundle.crt.
  • Place a CA bundle in the default location, this should be /etc/ssl/certs/ca-certificates.crt.

My suggestion is to try the first method by changing the file ~/.rccontrol/supervisord/supervisord.ini:

Look for a section called program:vcsserver-1_script and add a line like the following:

environment = SSL_CERT_FILE="/home/user/.rccontrol-profile/etc/ca-bundle.crt"

This way the VCServer will know where to look for the certificate bundle. After making the adjustments, the VCSServer should be restarted.

The whole section inside of the modified file supervisord.ini would look like the following example:

[program:vcsserver-1_script]
numprocs = 1
redirect_stderr = true
_port = 10002
_host = 127.0.0.1
command = /home/user/.rccontrol/vcsserver-1/profile/bin/vcsserver --config=/home/user/.rccontrol/vcsserver-1/vcsserver.ini
autostart = true
environment = SSL_CERT_FILE="/home/user/.rccontrol-profile/etc/ca-bundle.crt"
directory = /home/user/.rccontrol/vcsserver-1
stdout_logfile = /home/user/.rccontrol/vcsserver-1/vcsserver.log

Additional notes:

  • If you have multiple instances of the VCSServer running, you will have to replace vcsserver-1 with the correct instance name.
  • SSL_CERT_DIR should also be supported, this might be useful for more specific use cases where also custom CA certificates should be supported.

#23

Hi Johannes,

Thanks for the workaround. I tried both the methods, But no luck :frowning: . Getting the same Error message.


#24

Hi Pratap,

Did you restart supervisord completely after the change ?


#25

Hi Marcin,

I have restated supervisiord completely and tried to import repo, Now I am able to import the repo.
Thanks for the workaround and continuous support.


#26

Thanks for letting us know. We’re adding this now to the next release so it’s going to be added automatically by rccontrol to each installed instance.